[Réparation] - KTRONIX Z80

Discussions sur les anciens ordis souvent ludiques et familiaux (Amstrad, Atari, Amiga, ...).

Modérateurs : Membres WDA, Editeurs WDA

Avatar du membre
Krapoutchik
Contrôle WDA
Contrôle WDA
Messages : 1050
Enregistré le : 01 juil. 2009, 08:00
Collectionneur (-euse) ? : Oui
Localisation : Paris

[Réparation] - KTRONIX Z80

Message non lu par Krapoutchik »

KTRONIX Z80 .... hum... Cékoidon ?

Et hop... habile transition sur la réparation de la machine que Frktaunus a trouvé aux portes de l'enfer :mrgreen: et m'a gentiment donné :clap: .

On avait baptisé la machine Mimile mais, finalement, comme il y a la référence à KTRONIX Z80 dans l'eprom 0 , je rebaptise la machine KTRONIX 80 :8: .
Tiens, pendant que j'y suis, les voilà les eproms :D .
2532.zip
(15.39 Kio) Téléchargé 11 fois
Et, tant qu'à faire le schéma de l'adaptateur 2532 vers 2732 car mon programmateur d'Eprom (Elan 5000) ne sait pas faire la 2532
2532 ----------------------->2732
Pin 18 (A11)--------------->Pin 21 (A11)
Pin 21 (Vpp)--------------->Pin 20 (Vpp)
Pin 20 (CS) ---------------->Pin 18 (CS)
adapt2532.jpg
Sur la photo on voit que l'Eprom 0 a pris cher, céramique cassée, pattes tordues mais finalement elle fonctionne bien, ouf ! . J'ai dû la mettre sur un support intermédiaire car les pattes n'auraient pas supporté un enfichage et désenfichage. Sur l'adaptateur, le strap vers le CS est déconnecté, c'est normal, c'était juste pour un petit test.

Avant de mettre sous tension, comme d'habitude, faire le tour de la machine à la recherche de trucs bizarres, genre odeur de brulé, fusible HS, trace de brulure, fil abimé...

Ca commence par le fusible de l'alim à découpage qui est HS, un vilain domino isolé par du ruban adhésif pour raccorder le ventilo en 220, les fils du connecteur du secondaire du transfo abimés, les fils du fusible secteur sont tout entortillés, 2 tonnes de poussières et pour finir deux cadavres d'araignées :lol: .

L'interrupteur secteur a une résistance d'une trentaine d'ohms au lieu de 0 :eh: , démontage, nettoyage puis remontage. Si ce type d'inter se démonte très facilement, le remontage est une autre paire de manche la faute aux 2 petites billes en acier.
En fait il suffit de mettre une micro goutte de graisse pour coller les billes sur les ressorts situés dans le capot et le remontage se fait très facilement.
Inter avant
interavant.jpg
Inter après
interapres.jpg
Après vérification au multimètre (fonction beeper) je trouve un transistor, un condo et une zener en court-circuit et bien sûr le fusible.
alim KTRONIX Z80.jpg
Pour les électroniciens, un truc vraiment osé, directement en sortie du 5V et du 12V on trouve des zeners 6,2 pour le 5V et 13,6 pour le 12V, pas de résistances de limitations, rien de rien.
Tant qu'on est en dessous de 6,2 et 13,6 tout se passe bien (euh... enfin c'est relatif :eh: ) dès que la tension dépasse les valeurs de zener --> destruction des zeners qui sont des modèles de 1W et qui ne font pas le poids face à des transistors pouvant fournir 5 ou 6 A.
D'ailleurs, c'est ce qui a dû se passer sur le 5V, la zener s'est mise en court-circuit, par contre le transistor MJE15028 n'a pas apprécié et a fumé.
Intrigué par ce type de montage j'ai un peu investigué suite à la judicieuse remarque de Fneck sur le forum bleu des copains d'en face :mrgreen: .
Les zeners de l'alimentation sont du type BZV xxxx et cette référence, contrairement à la classique BZX xxxx, accepte des courants non-répétitifs d'environ 6 à 8 A et peut dissiper 60 watts, oui c'est bien 60 watts :eeeek:, pendant une centaine de micro-secondes :eek: qui peuvent parfois se produire sous forme de pulse en sortie d'alim à découpage.

Bon, une fois tout ce petit monde changé, branchement de l'alim, non pas sur le transfo mais sur une alim avec limiteur de courant.
En effet, vu les pannes et la connexion bizarroïde des zeners, je subodorais un truc pas catholique dans le fonctionnement de l'alim.
Bien m'en a pris, le 5V se baladait aux alentours de 7V et le 12 pas loin des 16V :eeeek: !

Après moult recherches, mesures, tests... j'ai trouvé :D !!

Chaque tension (5 et 12V) est générée par un circuit SG3524 ou LM3524 (c'est pareil), ces circuits comportent un petit régulateur 5V qui permet d'alimenter une référence externe réglable à l'aide de 2 résistances.
Sur un des 2 circuits cette référence était à 6,5V au lieu de 5V ::o , et, comme par hasard, ce 6,5V alimentait les références externes pour les 2 SG3524 ce qui décalait complètement le réglage des tensions.
Mega coup de chance, je n'ai pas de 3524 dans mes stocks mais j'ai pu interchanger simplement les 2 circuits qui étaient sur support.
Et voila ! tout est rentré dans l'ordre, enfin, c'est vite dit car le circuit qui donne la référence de tension est à 5,5V au lieu de 5V ce qui amène le 12 à 13V et le 5 à 5,40V en charge.
C'est un peu trop élevé à mon gout, il me reste à modifier le diviseur de tension à l'aide d'un petit ajustable pour que les tensions rentrent dans les clous.
Dès que ce sera fait, je pourrai envisager une mise à feu de la cpu :8: .
Tektronix 454A, Atten ADS 1102CAL Powa !!
Born to bricole
[Rch] Vieux composants électroniques et circuits intégrés toute époque et vieilles cartes à microprocesseur
Ma petite collection...
Tutoriel pour insérer des photos...
Avatar du membre
Krapoutchik
Contrôle WDA
Contrôle WDA
Messages : 1050
Enregistré le : 01 juil. 2009, 08:00
Collectionneur (-euse) ? : Oui
Localisation : Paris

Re: [Réparation] - KTRONIX Z80

Message non lu par Krapoutchik »

Après quelques heures de fonctionnement le SG3524 donnant 6,5V au lieu de 5V sur sa sortie de référence externe s'est envoyé en l'air avec moult odeurs puantes ::evil: . Mon disque dur suicide qui me sert de charge n'a pas aimé du tout, avant il ne marchait pas, maintenant il marche encore moins ::lol: .
Direction St Quentin radio, près de gare de l'Est à Paris et achat du dernier 3524 en stock :8: .
Re-re-re... test, je déclare l'alim bonne pour le service :D .
Entre temps j'ai nettoyé la carte mère, enlevé et remis tous les circuits sur supports, viré la batterie avant qu'elle ne fasse des dégâts, réglé un faux contact sur le 12V qui n'arrivait pas à la carte mère et...

Mise à feu :banana:
ktronix z80 ok.jpg
Je n'ai pas tout compris au fonctionnement du bousin, on peut écrire avec différentes tailles de caractères et d'espacement entre lignes, changer la date et heure, sauver le fichier sur disquette et imprimer.
Malgré le piteux état du clavier, toutes les touches fonctionnent correctement .
Pour l'instant je n'ai pas encore connecté le lecteur de disquette qui mérite la grande révision des 200 000 , il y a encore une petite pétouille sur la carte mère, le reset ne marche pas et, sur la carte vidéo que je n'ai pas encore nettoyée ::roll: , l'image saute de temps en temps. Par contre, l'image est nette et le tube n'est pas marqué
Je vais aussi aller fouiner du coté de l'interface série pour voir si ça discute avec l'extérieur, à propos, la grosse prise bizaroïde à l'arrière de la bécane est la sortie impression.
En bref, un petit peu de boulot :8: ...

Frktaunus a investigué sur cette machine, elle servait à créer des étiquettes d'impression sur plaque offset en pilotant une imprimante dédiée :clap: .
Tektronix 454A, Atten ADS 1102CAL Powa !!
Born to bricole
[Rch] Vieux composants électroniques et circuits intégrés toute époque et vieilles cartes à microprocesseur
Ma petite collection...
Tutoriel pour insérer des photos...
Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité