[Qst] - Supprimer un lecteur de cd-rom d'un "vieux" PC

Problème technique ou logiciel, plantages, ennuis viraux ou simplement nous faire part de votre expérience...

Modérateurs : Membres WDA, Modérateurs complets

henri_b
Posteur habitué
Posteur habitué
Messages : 15
Enregistré le : 15 déc. 2007, 18:35
Localisation : paris

[Qst] - Supprimer un lecteur de cd-rom d'un "vieux" PC

Message non lu par henri_b » 15 oct. 2012, 11:47

bonjour,

je suis en train d'alleger un "vieux" pc sous windows 2000 pour l'utiliser en continue dans une installation domotique perso. j'ai donc retiré lecteurs de d7, cartes, etc.. pour qu'il consomme moins et tout simplement parceque je n'en ai pas besoin... Par contre je n'arrive pas a enlever le lecteur de CD... si je le retire, le pc ne redemarre plus. l'ecran de demarage de windows reste figé et la barre de progression ne va jamais jusqu'au bout...
dans le bios je ne vois rien en rapport avec ce cd. dans windows j'ai fais "desinstaller" ("temporaire", pour le remettre en cas de besoin)... mais rien... bloque au demarrage... si je rebranche le cd, ca redemarre... une solution ?

c'est un dell pentium 3. la pile est morte (un rapport avec mon probleme?) mais je compte évidemment la changer...

MERCI

Henri b
Modifié en dernier par Casio le 15 oct. 2012, 15:10, modifié 1 fois.
Raison : Modif. par Casio : Nomenclature du titre...

En ligne
Avatar du membre
Krapoutchik
Bureau WDA
Bureau WDA
Messages : 896
Enregistré le : 01 juil. 2009, 08:00
Collectionneur (-euse) ? : Oui
Localisation : Paris

Re: [Qst] - Supprimer un lecteur de cd-rom d'un "vieux" PC

Message non lu par Krapoutchik » 15 oct. 2012, 13:24

Il y a de forte chance que ton lecteur de CD soit paramétré en "MASTER" et ton disque dur en "SLAVE".
Si tu enlève le lecteur de CD, la machine se retrouve avec seulement un périphérique "SLAVE" ce qui n'est pas une situation normale.

Il te faut donc paramétré ton disque dur en "MASTER" à l'aide des petits straps situés à l'arrière du disque dur. Si jamais tu veux remette ton lecteur de CD pour une raison ou une autre il te faudra le paramétrer en "SLAVE".

Normalement avec le disque de boot en "MASTER" sur la nappe principale, ta machine devrait booter même avec une pile morte mais il vaut mieux en mettre une neuve car tu peux avoir des valeurs abérantes dans la mémoire CMOS.
En plus en cas de reboot sauvage, panne de courant par exemple, ton Pc risque de se coincer au démarrage avec un message disant que tu dois régler la date et l'heure.
Tektronix 454A, Atten ADS 1102CAL Powa !!
Born to bricole
[Rch] Vieux composants électroniques et circuits intégrés toute époque et vieilles cartes à microprocesseur
Ma petite collection...
Tutoriel pour insérer des photos...

henri_b
Posteur habitué
Posteur habitué
Messages : 15
Enregistré le : 15 déc. 2007, 18:35
Localisation : paris

Re: [Qst] - Supprimer un lecteur de cd-rom d'un "vieux" PC

Message non lu par henri_b » 15 oct. 2012, 13:43

effectivement je n'avais pas pensé à ça... je viens de trouver la doc du disque (sur internet car sur le disque lui meme aucune info) et les jumpers sont effectivement en l'etat configurés en slave... je testerai donc demain en les changeant... par contre faut il du coup obligatoirement utiliser la nappe où etait le cd ou je peux laisser sur la nappe actuelle ? (au pire j'essaierai les deux...).

il y a aussi un jumper "cable select" utilisé. a priori ça sert a quoi ? a choisir une nappe justement ?

MERCI

ps : par contre je ne comprends pas pourquoi, si le pc cherche le master d'abord, pourquoi windows demarre quand meme (alors qu'il est sur le dd) ? ou plutot windows commence a démarrer mais s'arrete en cours de route...

En ligne
Avatar du membre
Krapoutchik
Bureau WDA
Bureau WDA
Messages : 896
Enregistré le : 01 juil. 2009, 08:00
Collectionneur (-euse) ? : Oui
Localisation : Paris

Re: [Qst] - Supprimer un lecteur de cd-rom d'un "vieux" PC

Message non lu par Krapoutchik » 15 oct. 2012, 15:38

Pour un disque de boot il est préférable d'utiliser la nappe sur le port IDE primaire qui peut-être plus rapide en terme de débit que le port secondaire.

Normalement le jumper "Cable Select" nécessite une nappe dont un des fils est coupé, mais honnêtement je ne me sers jamais de ce type de paramètrage, quand je branche des disques j'en mets toujours un en Master et l'autre en Slave et ce quelque soit la nappe utilisée.

Pour le démarrage qui se plante, mettre un périphérique unique sur un port IDE et le déclarer en Slave "ça ne se fait pas". La réponse est très certainement dans l'analyse du protocole de communication IDE mais, logiquement, Windows voit un esclave et, à un moment donné, il va chercher le master qui n'existe pas, c'est peut-être à ce moment là qu'il ratatouille.
Tektronix 454A, Atten ADS 1102CAL Powa !!
Born to bricole
[Rch] Vieux composants électroniques et circuits intégrés toute époque et vieilles cartes à microprocesseur
Ma petite collection...
Tutoriel pour insérer des photos...

henri_b
Posteur habitué
Posteur habitué
Messages : 15
Enregistré le : 15 déc. 2007, 18:35
Localisation : paris

Re: [Qst] - Supprimer un lecteur de cd-rom d'un "vieux" PC

Message non lu par henri_b » 16 oct. 2012, 11:35

bonjour,

j'ai donc joué avec les jumpers:
- dd en master sur sa nappe d'origine, cd en slave sur sa nappe a lui : marche pas
- dd en master seul (cd retiré) : marche pas
- dd master seul, sur la nappe du cd : marche pas

ca ne marche que dans la config d'origine : dd et cd en cs (cable select, aucun declaré en master ou slave) et chacun sur sa nappe et son connecteur

sous windows, je deconnecte le lecteur cd (il apparait plus dans le poste de travail) mais il le veut quand meme au demarrage, sinon ca ne marche pas...
pour info c'est un dell sous windows 2000
si je demarre en mode sans echec (cd debranché donc) ca ne va pas au bout du demarrage non plus... par contre en mode demarrage debugage là oui ça passe...

j'ai essaye avec un autre disque qui contient windows 98. je l'ai mis en CS pour rester dans la meme config que l'autre. Et la windows demarre avec ou sans le cd branché...

La je sais plus quoi essayer... HELP !

je pourrai tenter une desinstallation "definitive" du cd sous windows, mais le mot definitf me gene un peu... surtout que je n'ai pas les pilotes si je dois reinstaller au final...

En ligne
Avatar du membre
Krapoutchik
Bureau WDA
Bureau WDA
Messages : 896
Enregistré le : 01 juil. 2009, 08:00
Collectionneur (-euse) ? : Oui
Localisation : Paris

Re: [Qst] - Supprimer un lecteur de cd-rom d'un "vieux" PC

Message non lu par Krapoutchik » 16 oct. 2012, 21:31

En définitive et vu les tests que tu as réalisés je pense vraiment que le problème vient de la config soft W2000 puisque un W98 fonctionne correctement donc on peut mettre de coté le matériel.
Je ne me rappelle plus très bien la gestion des périphériques dans W2000 mais il me semble que tu peux désactiver un périphérique au lieu de le désinstaller, cela doit pouvoir résoudre ton problème.

Atchao
Tektronix 454A, Atten ADS 1102CAL Powa !!
Born to bricole
[Rch] Vieux composants électroniques et circuits intégrés toute époque et vieilles cartes à microprocesseur
Ma petite collection...
Tutoriel pour insérer des photos...

henri_b
Posteur habitué
Posteur habitué
Messages : 15
Enregistré le : 15 déc. 2007, 18:35
Localisation : paris

Re: [Qst] - Supprimer un lecteur de cd-rom d'un "vieux" PC

Message non lu par henri_b » 17 oct. 2012, 09:26

desactiver le peripherique c'est ce que j'ai fait... il n'apparait plus dans windows... mais il reste necessaire pour demarrer quand meme du coup... une suppression "definitive" je ne veux pas le faire (pour l'instant). Je vais donc toujours demarrer en mode "debugage" (dont j ne comprend pas en quoi il peut corriger ce probleme, mais il le fait...). Comme le pc est censé resté allumé, pour l'instant ca fera l'affaire... reste le probleme de la coupure de courant... la le pc ne pourrait plus redemarrer seul... :-(

merci quand meme des pistes.

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 0 invité